nixos_PC/shared/configuration.nix
2024-08-24 12:54:21 +02:00

33 lines
696 B
Nix

{ config, lib, pkgs, ... }:
{
environment.etc.configuration = {
target = "nixos/flake.nix";
source = "${config.variables.flakedir}/flake.nix";
};
fileSystems."/boot" = lib.mkForce {
device = "/dev/disk/by-label/NIXBOOT";
fsType = "vfat";
};
fileSystems."/" = lib.mkForce {
device = "/dev/disk/by-label/NIXROOT";
fsType = "ext4";
};
nix.settings.experimental-features = [ "nix-command" "flakes" ];
# Use the systemd-boot EFI boot loader.
boot.loader.systemd-boot.enable = true;
boot.loader.efi.canTouchEfiVariables = true;
nixpkgs.config = {
allowUnfree = true;
};
time.timeZone = "Europe/Copenhagen";
}
# vim: tabstop=2 softtabstop=2